Disable transport override

When I launch zrythm it overrides current jack transport settings (namely: bpm).

Is there a way to let zrythm slave to the current transport settings? it’s very annoying that the bpm of my session keeps getting changed.

this is missing from the manual, I need to add it soon here: Transport Controls — Zrythm 1.0.0-alpha.11.0.2 documentation

you can right click on the playhead position to select between

  • become jack transport master
  • sync to jack transport
  • no sync

Aaaaah ok, but it seems that this setting is not permanent? Every time I launch zrythm this value is reset.

Would’ve expected this to be in the settings to be honest (also I was clicking around on the BPM itself, but I guess I was just a bit too far to the left :wink: ).

[edit: yeah this setting is not even saved with the project, so the main point if this topic remains: allow zrythm to automatically slave on startup]

it’s supposed to be permanent, this was a bug. fixed in master

also updated the page here: Transport Controls — Zrythm 1.0.0-alpha.11.1.1 documentation

Top, will build and test!

[edit: confirmed! thnx for fixing this. Now zrythm will integrate much nicer :slight_smile: ]

1 Like