Zrythm only finds LV2 plugins on LInux (Arch Linux)

When I start Zrythm, only LV2 plugins show up on the right side panel. Neither VST2 nor VST3 are found by Zrythm. I tried both with trial version and my own compiled version (git version), but it seems has the same problem. Is it normal for now or am I missing something?

it should work with the trial or the paid binaries.
see https://manual.zrythm.org/en/plugins-files/plugins/scanning.html#vst2-vst3-scan for the scanning procedure.

try passing VST_PATH and VST3_PATH

I haved tried the method you mentioned, but it doesn’t work. I believe zrythm can find VST2 in the previous version. I could try to find that certain version if it is necessary.

NOTE: I have plugins in /usr/lib/vst/ and $HOME/.vst3

can you try with this and post the log (from the log file or console) after the plugins finish scanning?
https://www.zrythm.org/downloads/zrythm-1.0.0.alpha.0.1.1.r14.g8e53b108-installer.zip

Sadly, it still doesn’t works. There is log from my terminal.

I think zrythm need Carla to support vst2 and vst3 (correct me if l am wrong). I add three lines of code in plugin_manager.c

#ifndef HAVE_CARLA
printf (“no CARLA”);
#endif

I do get “no CARLA” output. Is that normal?

if you’re building from source, yes, you need latest Carla (from develop branch)

This is not the version I posted above: Zrythm-1.0.0-alpha.0.1.1-8-g20713e7c

I suspect you have multiple installations of Zrythm. Try running it from /usr/bin/zrythm_launch if you are using the installer, or zrythm_launch from the correct prefix if you are building it yourself

I suspect you have multiple installations of Zrythm.

You are right, sorry for that. I have updated my log file. Now It works successfully. Thanks a lot!

1 Like