Audio Inputs automatically switching to wrong input

I have noticed the following strange behaviour when selecting Inputs on audio tracks in Zrythm version 6.2.1.

  1. Create a new Audio Track.
  2. Select an input for the audio track.
  3. Click away from the track to start working.
  4. The input immediately changes to whatever is the first input in the list is.

This behavior also occurs in ver 5.3.1 and ver. 4.13.31 however, it does not occur in ver. 3.10.1.

I am running Arch Linux with Plasma X11 session.

Thanks for reporting it! I managed to reproduce it - will fix soon.

EDIT: fixed now

Thanks for looking into that. I am glad that you were able to reproduce the issue.

1 Like

I noticed that in the latest nightly build, ver 6.6.1 the input selection is no longer switching away from the input that I selected. However, now a different issue has been revealed. When I select an input, I don’t receive any audio on that track from my audio card. When I look a the Graph in QJackCtl - I can see that my input from my audio card goes into the corresponding input in zrythm… but still I cannot get the actual audio signal into the audio track…

However, if I connect my audio interface directly to the track in zrythm from within the qJackctl graph, I can now receive audio input on that track.

Did this not happen before? I don’t think the fix I did has any influence on what you’re describing. Also can you please provide exact steps to reproduce from an empty project? And is this always reproducible?

Yeah, I don’t believe the fix for the track selection has anything to do with this issue either- It was only revealed to me after the fix because I am now able to actually select tracks.

Steps to reproduce:

  1. Create a new audio track.

  2. Select an input (in my case It was a stereo track. My audio card has 4 outputs labelled capture_FL, capture_FR, capture_RL and capture_RR) I chose capture_RR and capture_RL.

  3. I hear no audio input. no levels appear in the track.

  4. When I look at the graph in QJackCtl, I see my audio card capture_RL, and capture_RR are connected to Zrythm’s capture_RL and capture_RR ports. Still, I can’t get any audio into the track.

see not-working screenshot:

  1. If disconnect eventhing in the QJackctl graph and then manually connect by dragging from my audio card outputs directly to the track inputs, I can now get audio coming into the track.

see working screenshot:

I am using pipewire-jack on arch Linux - Linux-zen 6.8.2 kernel, Latest Plasma desktop.

You need to enable the “monitor” button on the track if you want to hear the input.

Have you tried recording? Is there no sound recorded in the created audio regions?

I have monitor on and still can’t get audio into the track when I select the input in Zrythm. I can’t monitor or record audio.

When I connect the audio from the jack graph, it works as expected. I can monitor the levels and record audio.