Fedora Linux: I cant load any plugins

I downloaded zrythm 6.0.26 on fedora linux. I have been trying to load vst3 plugins put they are not showing up on the daw. I chose a custom location and put the .so file in a folder inside of plugins folder I chose. I also tried putting it into * $HOME/.vst, but still didnt work. Please help me with loading vst3 plugins

Hi, more information is needed.

  1. Is this the Flatpak version? How did you install Zrythm?
  2. Can you post the path you entered for VST3 here?
  3. What plugins have you tried with?

Thank you for helping

  1. I installed it by running bash install.sh that I downloaded from the offical page
  2. /home/jorvents/Documents/Canvas/Music/Software/plugins/vst3
  3. I have tried decentsampler and SurgeXT

I also have tried vst2


Can you please post the output of

ls -lh /home/jorvents/Documents/Canvas/Music/Software/plugins/vst3


Also can you try deleting the plugin cache file, then running Zrythm and letting it scan plugins, then send me the log file via DM?

ls -lh /home/jorvents/Documents/Canvas/Music/Software/plugins/vst3
total 0
drwxr-xr-x. 1 jorvents jorvents 32 Jan 14 21:10 DecentSampler
drwxr-xr-x. 1 jorvents jorvents 22 Jan 14 21:10 SurgeXT.so
I tried deleting the plugin cache file and didnt work.


these are not VST3 plugins, hence no VST3 plugins are scanned. VST3 plugins end in .vst3

When I downloaded the linux version of the plugin it came with this
ls -lh /home/jorvents/Documents/Canvas/Music/Software/Decent_Sampler-1.9.11-
My friend said I should put it in a folder the so file
I also tried putting it in the .vst3

This is what my plugin came with from the linux version:
total 18M
-rwxrwxr-x. 1 jorvents jorvents 9.1M Dec 18 18:00 DecentSampler
-rwxrwxr-x. 1 jorvents jorvents 8.7M Dec 18 18:00 DecentSampler.so
drwxrwxr-x. 1 jorvents jorvents 16 Dec 18 18:00 DecentSampler.vst3
-rw-rw-r–. 1 jorvents jorvents 1.2K Dec 18 18:00 readme.txt

I tried putting the DecentSampler.vst3 and deleted cached_plugin_descriptors.yaml (plugin cache file). It doesnt apear in the daw put it apears in the cache file

  • schema_version: 1
    author: Decidedly
    name: DecentSampler
    category: Instrument
    category_str: Instrument
    num_audio_ins: 0
    num_audio_outs: 2
    num_midi_ins: 1
    num_midi_outs: 1
    num_ctrl_ins: 2112
    num_ctrl_outs: 0
    num_cv_ins: 0
    unique_id: 0
    num_cv_outs: 0
    arch: 64-bit
    protocol: VST3
    path: /home/jorvents/Documents/Canvas/Music/Software/plugins/vst3/DecentSampler.vst3
    uri: 0xABCDEF01,0x9182FAEB,0x446C6479,0x44736D70
    min_bridge_mode: None
    has_custom_ui: 1
    ghash: 1353855265

Why its not apearing in the daw?

Can you post a screenshot of the plugin browser? Maybe you have filters enabled

Maybe its because its a folder with a .vst3 ending. It came like this

ls -lh /home/jorvents/Documents/Canvas/Music/Software/plugins/vst3/DecentSampler.vst3/Contents
total 0
drwxrwxr-x. 1 jorvents jorvents 30 Dec 18 18:00 Resources
drwxrwxr-x. 1 jorvents jorvents 32 Dec 18 18:00 x86_64-linux

Do i need to compile it?

The plugin seems fine. You have a category selected in Zrythm. Unselect it and it should appear.

No I have protocol selected

It acts weird. I cant select anything or deselect

Click this button in each tab until nothing has a badge that says says (1)

See this section in the manual for details (although it needs an update): Plugin Browser - Zrythm 1.0.0-beta.6.0.26 documentation

I can see the plugin now!
Sorry if asking here was dumb.
Thank you

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.