User not enough privileges on Ubuntu 22.04?

I’ve downloaded the free v1.0.0.rc.1 release to try on Ubuntu 22.04 since I’m very much looking forward to a decent DAW on Linux but I’m unable to properly run it.

I’ve extracted the .zip, ran the install shell script, it asked for my sudo password so filled it in, worked through the installer, so far so good.
But as soon as I run the DAW itself I get multiple pop-ups:

  • one that my user doesn’t have enough privileges to schedule priority of threads
  • one that my user doesn’t have enough privileges to allow Zrythm to lock unlimited memory
  • one “Backend initialization failed for JACK”
  • one JACK error: Overall operation failed

It does show me the UI and I can do about anything with it, except getting sound out of it(it seems).

Also I couldn’t find the link to the “Getting Started” anymore after install, would be nice if that would be included in the Troubleshooting section of “About Zrythm” or something so it’s easier to find after installation.

Running the zrythm_start shell script as root doesn’t fix the issues either.

When trying to load up the demo project instead it also throws a permission error:

Any ideas what I’m missing?

So I am running it on (Arch) Linux too, but via flatpak, so everything isn’t infinitely different.
Then, I installed realtime-privileges and added myself to the realtime group, to solve problem 1 and 2. Probably there is something similar for Ubuntu. Problem 3 and 4 could be solved too because JACK might be missing on Ubuntu but might be available on flatpak, but I am not sure.

The somehow funny thing about Zrythm is that on the download page, you have to pay for “full-featured” builds. But under the hood, everything is open source and you can get Zrythm from flathub (a linux app repository for flatpak). I am only speculating, but the payments on the website could be used for the binary compiling costs.

Please don’t ever run Zrythm as root. It probably broke a lot of things. The rest of your problems are not Zrythm bugs, Zrythm just tells you about what is the situation with external things.

That’s how it’s doen on Arch Linux. I’m not sure how Ubuntu does it but if you search you will probably find out (and maybe would be helpful to post the solutions here too for posterity).

Also you should make sure JACK is installed and running correctly if you want to use the JACK backend. The easiest solution is to use PipeWire.